?

Log in

Why I Hate Unix, Part V - Bending Reality to my Will

> Recent Entries
> Archive
> Friends
> Profile
> My Website

May 31st, 2005


Share Next Entry
04:05 pm - Why I Hate Unix, Part V

Had I any inkling of how much material I'd eventually have for this entry, I'd have started it a long time ago. I'm running Apple's OSX on a variety of systems, doing a variety of things, including web, mail, and DNS serving. I didn't think to actually record the horrible misery of trying to get Ruby installed, of trying to configure my server's printing system to be web-enabled correctly, of trying to get RubyCocoa to work, of failing to get Webmin to correctly install some mysterious Perl thing it needs to do https, of trying to install GIMP or Foomatic drivers instead of settling for Apple/HP's, and a few other adventures that didn't leave scars quite as deep.

I decide I'd like to add Report Magic to my web server to go with Analog. Lo, the only documented way to install it is through the Fink package. So first I have to get that.

It should be fairly easy to install Report Magic from source on Mac OS X 10.2 and later. You can use the fink command to install all the necessary packages including Report Magic itself.

To start with you need to download the Report Magic fink script from the Report Magic Add-on's page.

But wait, it gets better:

You will have to enable support for "unstable" packaged to allow this to work, as the lastest gd-pm package (used for graphics) are not classified as stable. You can do this from Fink Commander by selecting the "use unstable preferences" option under the "fink" tab. If you are not using Fink Commander, you can probably achieve this by adding "unstable/main" to the list on the "Trees:" line in your /sw/etc/fink.conf file.

So either I have to use Fink Commander, or I can probably do it by editing some mysterious line of my fink.conf file. As far as I'm concerned, "probably" means "impossible."

I follow the provided link to the Add-on page. There is no "Report Magic fink script" on the page, nor a link. All it says is "To install Report Magic and on your Mac OS X system, use fink or Fink Commander to get the rmagic package and install from there." I find Fink Commander by Googling. Before I install Fink Commander, I must install Fink.

There is a OSX-Installer package. Amazing. And too good to be true. After Fink is installed, I have to run it from the command line: fink scanpackages; fink index to (presumably) get it to update its records.

The web page also informs me

...you should update the fink package, in case there have been significant changes since the last point release...There are several ways to do this...

Use the included Fink Commander to select and install packages....The Fink Commander sequence to update fink from binaries is as follows:1, Binary->Update descriptions; 2, Select the fink package; 3, Binary->Install

[or] To update fink run fink selfupdate. When prompted, select option (1), "rsync". This will automatically update the fink package.

I have a command line open, so I decide to go with the latter, simpler options. Doesn't work. I'm told that I'm using the wrong compiler: gcc 3.1, not gcc 3.3. But hey, not to worry, I can fix that by typing sudo gcc_select 3.3.

Doesn't work. gcc_select informs me that "3.3" is not valid. My choices are "2" or "3" nothing more. Apparently my gcc_select doesn't work like the one used by the Fink people.

OK, no problem. I'll try updating it a different way, using Fink Commander. If I install binary files instead of source, then it won't need to compile, and this 3.1 business will be avoided.

Yea. Right.

Reading Package Lists...
Building Dependency Tree...
Sorry, fink is already the newest version.

Huh??

0 packages upgraded, 0 newly installed, 0 to remove and 1  not upgraded.
1 packages not fully installed or removed.
Need to get 0B of archives. After unpacking 0B will be used.

Huh? Zero Bee?

Setting up fink (0.23.10-11) ...
Checking system... powerpc-apple-darwin7.8.0
Under Mac OS X 10.3.8, Fink must be bootstrapped or updated using
gcc 3.3.  However, you currently have gcc 3.1 selected.
To correct this problem, run the command:

    sudo gcc_select 3.3

dpkg: error processing fink (--configure):
 subprocess post-installation script returned error exit status 255
Errors were encountered while processing:
 fink
E: Sub-process /sw/bin/dpkg returned an error code (1)

How is it I've got 3.1 in the first place? This is probably an artifact of when I was trying to get Ruby installed, and was told that 3.3 was bad and I needed 3.1 to get it to work. That turned out to not be true (it didn't work in either case), but that's probably why this isn't working. I go to /usr/bin and find "gcc" is linked to gcc-3.1. I change the link, and fink selfupdate again.

Doesn't work. It still complains about 3.1. I copy "gcc3" to "gcc-3.1", and replace "gcc3" with a copy of "gcc-3.3". By the Powers of Osiris, fink selfupdate.

I get much further this time. It makes me select new mirrors for the Apt-Get Repository (whatever that is) and "The GIMP" (but I'm not updating the printing system!), before attempting to actually start updating Fink.

checking whether the C compiler (gcc -L/sw/src/gettext-0.10.40-19/gettext-0.10.40/intl/.libs -L/sw/lib) works... no

No? No?

Well, let's see. I could use fink Commander to try installing/updating gcc3.3, and see if I get a later version. It says that the current version of gcc3.3 is 4.3.51-8. What version do I have? gcc version 3.3 20030304 (Apple Computer, Inc. build 1666) So, is "4.3.51-8" > "20030304"? I have no {censored} clue.

Oh, but wait! I wasn't required to update Fink! So I could just install Report Magic without updating! Ha ha, it is to laugh. There is no such package rmagic in Fink Commander's list of available packages.

Screw this. There's no way Report Magic could be worth any more time in this demonic realm. I give up.


Current Mood: aggravatedaggravated

(Leave a comment)


> Go to Top
LiveJournal.com